We are in the process of migrating this forum. A new space will be available soon. We are sorry for the inconvenience.

Ioncube


freakt
06-09-09, 21:24
echo "Extraction complete. To activate the loader add the following line to /usr/local/lib/php.ini, before any other zend_extension lines. Then restart httpd"

Dat ook gedaan?
als je nu nog de fout krijgt van de 5.1 zorg dat je juiste PHP.ini settings file hebt. en dat het er goed instaat.

of geef gewoon even de gegevens aan iemand op WHT die je wilt helpen of iemand hier... en denk eens na over wat Randy daar zei...

EDIT: te laat, blij dat het opgelost is. Goed dat je dit gaat delen met de andere leden...

alexweblog
06-09-09, 21:23
freakt bedank voor uw hulp ik heb het voor elkaar en het werkt ik al komende week een how to schrijven voor de mede gebruikers

Fijne avond verder freakt

alexweblog
06-09-09, 21:18
Ik heb geprobeerd wat u zegt maar het help niet

freakt
06-09-09, 21:07
zoals hier de raad ook even volgen :-) http://www.webhostingtalk.nl/dedicat...kt-niet-2.html

zorg dat je de juiste ioncube hebt voor jouw versie...

EDIT: Haal die ioncube weg en doe dit:
# wget http://www.watters.ws/scripts/install-ioncube.txt
# sh install-ioncube.txt

alexweblog
06-09-09, 20:57
ik krijg de error er niet uit

Failed loading /usr/lib/php/modules//php_ioncube_loader_lin_5.1.so: /usr/lib/php/modules//php_ioncube_loader_lin_5.1.so: undefined symbol: zend_unmangle_property_name_ex

alexweblog
06-09-09, 20:28
Ok yes het is me gelukt de error heeft te maken met de sitebuilder van plesk die heb ik gedelete met yum remove php-sqlite2 vervolgend yum update php gedaan en de httpd gerestart en krijg nu bij mij output:

Failed loading /usr/lib/php/modules//php_ioncube_loader_lin_5.1.so: /usr/lib/php/modules//php_ioncube_loader_lin_5.1.so: undefined symbol: zend_unmangle_property_name_ex
PHP 5.2.9 (cli) (built: Mar 10 2009 16:42:52)
Copyright (c) 1997-2009 The PHP Group
Zend Engine v2.2.0, Copyright (c) 1998-2009 Zend Technologies

krijg nu alleen een error van ioncube nu proberen die weer op te lossen.

alexweblog
06-09-09, 20:18
Oke heb het volgende gedaan maar krijg een error:

wget -q -O - http://www.atomicorp.com/installers/atomic.sh | sh
yum update php


Error: Missing Dependency: php <= 5.2.0 is needed by package php-sqlite2

Hoe kan ik dit nu oplossen vanmorgen ging dit ook fout

alexweblog
06-09-09, 20:06
Ik heb CentOs 5.2 met het panel plesk

freakt
06-09-09, 19:48
Citaat Oorspronkelijk geplaatst door alexweblog
Ik weet dus nu nog niet hoe ik php moet update kun jij me misschien een stap verder helpen??
OS? Panel?

psst volgende geeft ook vaak wat en post je bevindingen ook even hier dan leren er anderen ook wat van.
Google: update php <> <>

alexweblog
06-09-09, 19:44
Ik weet dus nu nog niet hoe ik php moet update kun jij me misschien een stap verder helpen??

freakt
06-09-09, 19:37
Citaat Oorspronkelijk geplaatst door alexweblog
ja freakt ik vind het fijn dat je me helpen wil maar ik heb vanmorgen geprobeerd om php te updaten maar dat ging compleet fout waardoor ik kon herinstalleren
Een herinstallatie is echter niet nodig als er iets fout gaat hoor. Een php rebuild zou eventueel we voldoende geweest zijn hoor...

Denk niet dat iedereen zomaar zich kan veroorloven zijn server te herinstalleren

alexweblog
06-09-09, 19:21
ja freakt ik vind het fijn dat je me helpen wil maar ik heb vanmorgen geprobeerd om php te updaten maar dat ging compleet fout waardoor ik kon herinstalleren

freakt
06-09-09, 18:52
Citaat Oorspronkelijk geplaatst door alexweblog
Heb php geprobeerd te update maar dat ging fout dus ben nu met herinstall bezig
Zoals ik hier zie de oplossing gevonden: http://www.webhostingtalk.nl/dedicat...ml#post1084232
(php update zoals ik hierboven vermelde...)

alexweblog
06-09-09, 09:28
Heb php geprobeerd te update maar dat ging fout dus ben nu met herinstall bezig

freakt
05-09-09, 21:51
als cast control de laatse loader nodig heeft zal je jouw PHP moeten updaten en de laaste loader voor die versie moeten gebruiken.

alexweblog
05-09-09, 20:17
hier de uitdraai van php -v
PHP 5.1.6 (cli) (built: Apr 7 2009 08:00:04)
Copyright (c) 1997-2006 The PHP Group
Zend Engine v2.1.0, Copyright (c) 1998-2006 Zend Technologies
with the ionCube PHP Loader v3.1.16, Copyright (c) 2002-2006, by ionCube Ltd.

en in php.ini staat die ingesteld.

Ja als je graag zelf wat wil oplossen dan zoek je op meer forum's hulp he

Alvast bedankt voor je reactie

freakt
05-09-09, 20:01
Wat geeft het volgende comand in de command line?
php -v
Daar zou iets van ionCube loader moeten staan.

Zoniet zorg dat je php.ini juist ingesteld is. Zend installeren en die extension inladen net voor de [Zend] (op het einde)

php.ini vinden (find, locate etc...)?
whereis php.ini
Zorg dat je ook de goede versie hebt (i386 of de x86_64)

EDIT (beetje fout gelezen)

Citaat Oorspronkelijk geplaatst door alexweblog
The file index.php cannot be decoded by this version of the ionCube Loader. If you are the administrator of this site then please install the latest version of the ionCube Loader.
Zeker dat het de laatste versie is, vergelijk even met het php -v command. http://www.ioncube.com/loaders.php

Controleer ook even welke versie castcontrol nodig heeft...

Toevallig hier ook hulp aan het zoeken http://www.webhostingtalk.nl/dedicat...erkt-niet.html

Dingen die je nog kan nagaan, php up to date voor cast control? geen andere modules nodig voor cast control? ...

alexweblog
05-09-09, 16:55
Ik heb op mijn server ioncube geinstalleerd en als ik vervolgens de ioncube-encoded-file.php check dan zegt die:
An ionCube Loader file is required by PHP to read files encoded with the ionCube Encoder. This page will determine how you can install Loaders on this particular server.

An ionCube encoded file has been loaded successfully.
Encoded files should now function correctly.

If you have a problem with your PHP application, please contact the application provider.


Maar op het moment dat ik nu castcontrol probeer te installeren krijg ik:

The file index.php cannot be decoded by this version of the ionCube Loader. If you are the administrator of this site then please install the latest version of the ionCube Loader.

Maar nu is het verhaal dat ik wel de laatste versie heb draaien dus ik snap nu niet meer wat ik moet doen.
Gr,
Alex