We are in the process of migrating this forum. A new space will be available soon. We are sorry for the inconvenience.

VPS, geen rechten om tijd in te stellen?


freakt
04-09-09, 04:23
Beetje veel te laat maar mogelijk zullen anderen hier nog wat aan hebben.

Tijd zone instellen
ln -sf /usr/share/zoneinfo/Europe/Amsterdam /etc/localtime
Kijk ook even in het mapje /usr/share/zoneinfo/ voor andere tijd zones

Tijd instellen en correct houden! [RHEL - CENTOS,FEDORA,...]
yum -y install ntp
ntpdate ntp0.ovh.net
/etc/init.d/ntpd start
chkconfig ntpd on

Tijd instellen en correct houden! [DEBIAN,UBUNTU,...]
apt-get -y update
apt-get -y install ntp ntpdate
ntpdate ntp0.ovh.net
/etc/init.d/ntp start
update-rc.d -f ntp defaults

Tijd instellen en correct houden! [DEBIAN,UBUNTU,...] (als je not permitted krijgt)
sudo apt-get -y update
sudo apt-get -y install ntp ntpdate
sudo ntpdate ntp0.ovh.net
sudo /etc/init.d/ntp start
sudo update-rc.d -f ntp defaults
ntp verloopt over poort 123 (UDP); dus firewalls (iptables of enige andere firewall) even op ACCEPT plaatsen voor die poort (uitgaand)


Let op bij virtualisatie software zoals openVZ kan het soms zijn dat de tijd niet aangepast mag worden, dit wordt dan door de hoofd node bij gehouden (zorg dat timezone goed staat! of geef de VPS toegang hiervoor "sys_timen")

Scriptman
10-08-09, 14:02
Een late reactie, excuses, maar het schijnt dat er plotseling opeens sudo op die VPS stond.. op een of andere manier moest ik nogmaals inloggen als root via "sudo su -l".

Toch bedankt voor de hulp en tips!

Sphinx
28-06-09, 12:36
Je hoeft alleen `date [MMDDhhmm]` doen. Zonder haakjes, streepjes of dubbelepunten.

Scriptman
27-06-09, 17:57
vps03:/etc/apache2/sites-enabled# whoami
root

Maargoed, intussen heeft mijn broetje het al gedaan, maar alsnog snap ik het niet waarom ik geen rechten daartoe heb.

Betatester123
27-06-09, 15:17
ben je wel ingelogd met root op die server?

wat geeft: whoami weer?

Scriptman
27-06-09, 14:57
Beste,

Ik gebruik mijn server voor VPSjes.
Echter staat de server tijd wel goed, en bij alle vpsjes ook, behalve bij 1 vps.
Op die vps heb ik ISPCP geinstalleerd, echter als ik inlog met root rechten krijg ik de volgende melding bij het instellen van de tijd:
Code:
vps03:~# date
Sat Jun 27 12:02:17 UTC 2009
vps03:~# date --set 14:02:19
date: cannot set date: Operation not permitted
Sat Jun 27 14:02:19 UTC 2009
vps03:~#
Weet iemand hoe dit kan?
De UTC moet namelijk UTC+2 zijn.. hoe kan ik dit anders instellen?

Mvg,
Mario Lamers