We are in the process of migrating this forum. A new space will be available soon. We are sorry for the inconvenience.

php 5.2.6 updaten


nyan
10-06-12, 11:25
kan je in je control panel niet ergens php updaten?
Ik kan mij herinneren dat je in plesk gewoon op server->software->updates en dan alles up kon daten.

peppi
09-06-12, 17:46
Ik weet niet zeker wat je daarmee bedoelt ?
Maar ik denk dat je bedoelt of ik een admin pannel heb en daar de sites in geconfigureerd hebt of niet ?

var/www/virtual daar staan dus de sites
het admin pannel is ispcp (drama dus ivm support)
server is debian lenny

welke files/configs moet ik backuppen voordat ik de update zou doen ?
uiteraard zal ik alles eerst testen op de homeserver voordat ik de ovh server verknal



Citaat Oorspronkelijk geplaatst door nyan
heb je je websites toevallig gedefineerd in /etc/apache2/sites-available/default ?
dan moet je dat natuurlijk wel backuppen voordat je upgrade.. je moet zoiezo altijd je config files backuppen voordat je upgrade.

nyan
09-06-12, 12:30
heb je je websites toevallig gedefineerd in /etc/apache2/sites-available/default ?
dan moet je dat natuurlijk wel backuppen voordat je upgrade.. je moet zoiezo altijd je config files backuppen voordat je upgrade.

peppi
08-06-12, 21:19
Citaat Oorspronkelijk geplaatst door nyan
wat wordt er verknald?
apt-get update
add dotdeb to sources
apt-get update
apt-get install php5
apt-get install libapache2-mod-php5
/etc/init.d/apache2 restart
verwijder dotdeb van sources
apt-get update
Oei zo technisch ben ik ook weer niet
Maar het komt erop neer dat niets meer werkt
Naar mijn idee als ik de php overschrijf dat er dan bepaalde files wijzigen waardoor er niets meer werkt
ik bedoel dan de websites uiteraard

of het is een kwestie van eigenaren of rechten van bestanden dat zou ook kunnen

ik heb namelijk de procedure hierboven beschreven op de homeserver even getest en daar had ik ook even een url en website opgezet deze werkte vervolgens niet meer

nyan
08-06-12, 21:08
wat wordt er verknald?
apt-get update
add dotdeb to sources
apt-get update
apt-get install php5
apt-get install libapache2-mod-php5
/etc/init.d/apache2 restart
verwijder dotdeb van sources
apt-get update

peppi
08-06-12, 15:22
Citaat Oorspronkelijk geplaatst door Betatester123
apt-get update / upgrade?

Anders even kijken in de repo van dotdeb: http://www.dotdeb.org/
was het maar waar dat het zo easy was dan was het al gfxt
als ik bij die dotdeb kijk en daar de instructies van volg dan wordt dus alles verknalt
Ik heb even een home servertjs ingericht en toen die upgrade gedaan en eerst even de source aan de list toegevoegd daarna was het dus een feesie op die server

Betatester123
07-06-12, 18:09
apt-get update / upgrade?

Anders even kijken in de repo van dotdeb: http://www.dotdeb.org/

peppi
06-06-12, 18:11
joehoe is there anybody out there (pink floyd)
het is voor mij toch wel een isseu om dit voor elkaar te krijgen

Citaat Oorspronkelijk geplaatst door peppi
op 1 van mijn sites krijg ik de melding :

1 critical issue(s) detected.
•PHP version 5.2.6-1+lenny10 is too old. Make sure to install 5.2.7 or newer.


nu heb ik al eens eerder de fout gemaakt om met de php te rommelen en toen ging alles goed fout en was ik eigenlijk zo goed als alles kwijt
mijn vraag is nu dan ook een goede beschrijving met de bijbehorende commando's om de php versie te updaten zonder alles kwijt te raken

ik lees wel het een en ander op het web maar durf er nu niet zomaar aan te beginnen

peppi
04-06-12, 00:32
op 1 van mijn sites krijg ik de melding :

1 critical issue(s) detected.
•PHP version 5.2.6-1+lenny10 is too old. Make sure to install 5.2.7 or newer.


nu heb ik al eens eerder de fout gemaakt om met de php te rommelen en toen ging alles goed fout en was ik eigenlijk zo goed als alles kwijt
mijn vraag is nu dan ook een goede beschrijving met de bijbehorende commando's om de php versie te updaten zonder alles kwijt te raken

ik lees wel het een en ander op het web maar durf er nu niet zomaar aan te beginnen