OVH Community, your new community space.

Anyone successfully installed/upgraded to OpenIndiana/Solaris 11 Express

04-06-11, 21:59
Euuh. Dit forum is Nederlands hoor

03-06-11, 22:46
In case anyone comes across this thread and wonders if I found a solution, the answer is yes and now. I never managed to install OpenIndiana on the bare metal. The solution I needed to employ was to install a Linux hypervisor and create a virtual machine for OpenIndiana. It's not my preferred solution but it works fairly well nonetheless.

09-05-11, 15:24
I've been trying to figure this out but I seem to be going nowhere fast. I've searched on the forum and on the net but so far have been unlucky in finding any results.

What I would like to achieve is to have OpenIndiana installed. I first attempted this by using the control panel to install opensolaris. I then attempted to upgrade to 134 using the openindiana legacy repository but I ended up with a system that booted once after upgrade with strange behaviour (segmentation faults, python libraries missing, etc) and then any subsequent reboots failed. Using vkvm I see a message that it could not load the ramdisk. The system no longer works at all unless I reinstall it. I thought this might be a problem with the openindiana repo so then tried upgrading to 134 using the oracle repo following the solaris 11 express update instructions. I ended up with the same result.

I then tried to install OpenIndiana using vkvm and an iso over ftp. The install works without any problems. Still using vkvm, I can boot the system. I configured the network settings and rebooted without vkvm but the server never comes up.

If I reattach vkvm the server boots up but from the logs I can see that it did not boot without vkvm but there is no indication as to why. To make matters worse the virtualised vkvm environment makes troubleshooting very difficult because it is clearly not the same as looking at the machine through a hardware kvm. All the hardware on the machine is different, even the network card has a different mac address and driver. This makes any kind of troubleshooting nearly impossible. Why does it boot in vkvm but not without it?

Has anyone had any kind of success with doing this or something similar?